CLIPS Tutorial 1

Introduction to CLLIPS
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CLIPS in PC

m CLIPS is a tool for building expert systems.
http:/ /clipstules.sourceforge.net/index.html

m CLIPS is a multiparadigm programming language that provides
support for rule-based, object-oriented, and procedural
programming.

® You can download it from:
http:/ /soutrceforge.net/project/showfiles.phpreroup_id=215471
&package 1d=260062

= Download CLIPSWin.zip
m Extract the zipped file.
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CLIPS in PC

®m Or accessing CLIPS in SE laboratories through the path
“N\Sepc637\seg7450”

4 seg 7450 on Sepc63T
File. Edit Wiew Favorites Tools  Help

@Eiacl::. il > | 1? j.- ) sgarch '_ Folders v

Address | b \\SepchaTseg7450

File and Folder Tasks

Other Places
CLIPSWin. zip

401 KB

Details

seq 450
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CLIPS in PC

® Double click the program “CLIPSwin.exe”

& C|IPSWin
File Edit Miew Favorites Tools  Help

Q Back - ‘T]‘ / ) Search

Address |23 Ciseq7450 CLIPSWin

File and Folder Tasks ¥ ’ CLIPSWin.exd [y ||=F:'|E| |

CLIFS (Ve&.24 06/15/06)

a3
Oher Places Sl ™ readmett [cLIPS> |

Text Documey
[ 520?450
._j My Documents
J My Computer

&g My Metwork Places

2 kB

Details

CLIPSWin
File Folder

Date Modified: Today, October
25, 2007, 12:52 PM




CLIPS in PC

Select File -> Load to load a clips program : _
CLIPS 6.24 - [Dialog Window]

SClCCt Execution -> Reset to reset memory BN Edit  Buffer Execuktion  Browse  ‘Window  Help

. e el
Select Execution -> Run to execute the ”Fn o

progfam ) Load... Chrl+L
- Load Batch. ..

Select Execution -> Clear CLIPS to clear the Load Binary. ..
memory Turn Dribble On..,

./ 15/06)

Select Browse -> Deffacts Manager to list the Ctri+
name of deffacts construct y

Select Browse -> Deftemplate Manager to
list the name of Deftemplate construct Page Setup...

Prink... Chrl4+-P
Select Window -> Facts to list the facts in
memory

Select Window -> Agenda to list the rule to be
fired at the current step

Select Window -> Globals Window to list the

globals variance

Exit
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CLIPS in PC

CLIPS 6.24 - [Dialog Window] | N TO dACCECSS CLIPS

@} File Edit Buffer Execution Browse ‘Window N

0 |E’:|E| | | | ghq Abaut CLIPS. .. Help

CLIFS (Ve&.24 06/15/06)

CLIPS>
v Shtatus Line

Windows Help X]

@ Cannat find the CLIPS6,HLF file, Do wou want ka by ba find this file vourself? Look in: | (= CLIPSWwin

ﬁ'_.})CLIF‘SIS.HLF‘
;;

Ity Recent
Documents

i

Desktop

~</,

tdp Diocuments

Display on-line help -
%58
tly Compuiter
by Metwork File name: |EILIF'SE.hIp
Flaces

Files of type: |Help Files
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CLIPS in PC

CLIPS 6.24

File Edit Buffer Execution Browse Window HEF
D|e(d| | | &2

£ Dialog Window

b

Defining defrule: remove-rule-no-match +3+4] [variable family feet)

Defining defrule: modify-rule-mwatch =347 [wvariasbhle live.in.water no)

Defining defrule: rule-satisfied =j4+j [wvariable genus dry)

Defining defrule: ask-gquestion-no-legalvalues +3+34+34+3 [wvariable front.teeth no)

Defining defrule: ask-question-legalvalues +j+j+] [variable species noteeth)
deffacts: knowledge-hase [wvariskble pouch no)

[varishle type.animal molefshr -
[reset)

CLIPS> (run)

Does your animal have a backlbone? [(yes no) yes

Iz the animal warim blooded? [(yes no) yes

Normally, does the female of wour animal nurse its young with milk? (yes no) wye

Does animal eat red meat? (yes no) no

Does animal hawve hoowves? ([(y¥e3 no)] no

Does animal live in water? (yes no) no

Does animal hawve large front teeth? [(ves no) no

Does animal hawve a pouch? (yes no) no

I think your animal is a wole/shrewv/elephant

CLIFPS>

m " ppr—

mEE




CLIPS in PC

= Download CLIPS 6.24 and its help

Enter web site
http:/ /sourceforge.net/project/showfiles.phpreroup_id=215471&package_id=26
0062

Select Release 6.241

Download clipswin_executable_6241.zip

Unzip and extract CLIPSWin.exe & CLIPSG6.hlp to the same directory in your PC..
® Download CLIPS examples

Enter web site
http:/ /sourceforge.net/ project/showfiles.phpreroup_id=215471&package_id=206
0062

Select Release 6.24
Download and extract examples_624.zip to your PC.

m Download CLIPS user guide
m Click http://clipsrules.sourceforge.net/OnlineDocs.html.

m For others materials, you can visit http://clipstules.sourceforge.net/index.html
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CLIPS Programming

®m Basic elements of an Expert System
m Fact-list : Global memory for data
= Knowledge-base : Contain all the rules
= Inference Engine : Control overall execution
m A program in CLIPS consists of

m Facts

m Rules
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Entering and Exiting CLIPS

The CLIPS prompt appear as follows:

CLIPS>
Commands can be entered directly to CLIPS; this mode is called the 7op level.
The normal mode of leaving CIIPS is the exit command.

(exit)
Each CLIPS command must have a matching number of left and right
parentheses.

The final step in executing a CLIPS command after it has been entered with
propetrly balanced parentheses 1s to press the return key.

CLIPS> (+ 3 4) !
-
CLIPS> (exit)

SEG 7450




Entering and Exiting CLIPS

m A symbol surrounded by parentheses is considered to be a command or
function call.

m The input (+ 3 4) is a call to the + function.

m  The input (exit) invokes the ex7# command.
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Fields

m Tokens represent groups of characters that have special meaning to CLIPS.
m  The group of tokens known as fields is of particular importance.
m  There are eight types of fields, also called the CLIPS primitive data types:

m float,
integer,
symbol,
string,
external address,
fact address,
instance name, and
instance address.

m CLIPS is case-sensitive.
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Fields

A symbol is a field that starts with a printable ASCII character and is followed by zero
or more characters.

m  The end of a symbol is reached when a delimiter is encountered.
s Delimiters include any nonprintable ASCII character. (spaces, tabs, returns, line feeds) and
T & | <~
Symbols cannot contain delimiters.
E.g.
®  Space-Station
m Fire
m activate_sprinkler system
A string must begin and end with double quotation marks, which are part of the field.
s E.g. “Active the sprinkler system.”
External addresses represent the address of an external data structure returned by a
user-defined function.
A fact address 1s used to refer to a specific fact.

An instance address is like a fact address, but it refers to an instance rather than a fact.

A series of zero or more fields contained together is referred to as a multi-field value.
A multifield value is enclosed by left and right parentheses.
= Eg.

= ()
m (this that)
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Facts

To solve a problem, a CLIPS program must have data or information with
which it can reason.

A “chunk” of information in CLIPS is called « fact.

Facts consist of a relation name followed by zero or more slots and their
associated values.
The following is an example of a fact:
(person (name "John Q. Public”)
(age 23)
(eye - color blue)
(hair - color black))
The symbol person is the fact's relation name and the fact contains four slots:
name, age, eye-color, and hair-color.
® The value of the name slot is “John Q. Public”
® The value of the eye-color slot is blue.
m The value of the hair-color slot is black.
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Facts

m  The order in which slots are specified is irrelevant. The following fact is
treated as identical to the first person fact by CLIPS.

(person (hair - color black)
(name "John Q. Public”)
(eye - color blue)
(age 23))
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The Deftemplate Construct

Before facts can be created, CLLIPS must be informed of the list of valid slots
for a given relation name.

Groups of facts that share the same relation name and contain common
information can be described using the deftemplate construct.
The general format of a deftemplate is:
( deftemplate <relation - name> [<optional - comment>]
<slot - definition>*)
The syntax description <slot-definition> is defined as:
(slot <slot -name>) | (  multislot <slot - name>)
The deftemplate for the person fact:
( deftemplate person "An example deftemplate
(slot name)
(slot age)
(sloteye - color)
(slot hair - color))
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Multitield Slots

m  Multislot keyword in their corresponding deftemplates are allowed to contain
zero or more values

(person (name John Q. Public)
(age 23)
(eye - color blue)
(hair - color brown))

is illegal if name 1s a single-field slot, but legal if name is a multifield slot.
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Ordered Facts

Facts with a relation name that does not have a corresponding deftemplate

are called ordered facts.

For example, a list of numbers could be represented with the following fact:
m (number - list 79 3 4 20)

There are two cases in which ordered facts are useful.

m TFacts consisting of just a relation name are useful as flags and look
identical regardless of whether a deftemplate has been defined. For
example,

m (all -orders - processed)
m For facts containing a single slot, the slot name 1s usually synonymous
with the relation name. For example, the facts:
(time 8:45)
(food - groups meat dairy bread
fruits - and- vegetables)
m are as meaningful as:
(time (value 8:45))
(food - groups (values meat dairy bread
fruits - and- vegetables))
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Ordered Facts

m A deftemplate fact is a non-ordered fact.
B Ordered versus Non-ordered

m Otrdered facts encode information with fixed position which is not
convenient to access

= (Clarity and slot order independence are virtues of deftemplate facts
s Extra command (e.g. modify, duplicate) for non-ordered facts

SEG 7450




Dettemplat

e Overview

(number-list 7 9 3 4 20)

Construct

IS-AT

Deftemplate

Implied Explicit
Deftempiate Deftempiate

Creates Creates

FACT

IS-A 1S-A

Deftemplate
Fact

Ordered
Fact

IS-A IS-A

(person)
R

Fields Slots

Relation Name

(deftemplate person
(multislot name)
{slot age)

(slot eye-color)
{slot hair-color))

(name John Q. Public) Multifield Slot
(age 23)
{eye-color blue)

(hair-color brown))

/N

Slot Name Slot Value
(a field)

Single-field Slots
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Manipulation of Facts -- assert

m  Basic commands to operate on facts:
® assert, retract, modify, duplicate, facts

= Adding Facts

m  New facts can be added to the fact list using the assert command.
(assert <fact>+)
= As an example,
CLIPS>
( deftemplate person
(slot name)
(slot age)
(slot eye - color)
(slot hair - color))
CLIPS>
(assert (person (name "John Q. Public")
(age 23)
(eye - color blue)
(hair - color black)))
<Fact - 0>
CLIPS>
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Manipulation of Facts -- assert

m  More than one fact can be asserted using a single assers command. For
example, the command:

(assert (person (name "John Q. Public")
(age 23)
(eye - color blue)
(hair - color black))

(person (name "Jane Q. Public")

(age 36)
(eye - color green)
(hair - color red)))
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Manipulation of Facts -- facts

m Displaying Facts
= The facts command can be used to display the facts in the fact list.

(facts)

For example,

CLIPS> (facts)

f-0 (person (name "John Q. Public")
(age 23)
(eye - color blue)
(hair - color black))

For a total of 1 fact.

CLIPS>

Every fact that is inserted into the fact list is assigned a unique fact
identifier starting with the letter fand followed by an integer called the fac?
mdex.
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Manipulation of Facts -- facts

m  The complete syntax for the facfs command is:
(facts [<start> [<end> [<xmaximum>]]])

where <start>, <end>, and <maximum> are positive integers.
If no arguments are specified, all facts are displayed.

If the <start> argument 1s specified, all facts with fact indexes greater than or
equal to <start> are displayed.

If <start> and <end> are specified, all facts with fact indexes greater than or
equal to <start> and less than or equal to <end> are displayed.

Finally, 1f <maximum> is specified along with <start> and <end>. no more than
<maximum?> facts will be displayed.
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Manipulation of Facts -- retract

® Removing facts

= Removing facts from the fact list is called rezraction and 1s done with the
retract command.

m The syntax of the refract command is:
(retract <fact - iIndex>+)
(retract 0)

= A single refract command can be used to retract multiple facts at once.

(retract 0 1)
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Manipulation of Facts -- modify

m  Modifying facts
m Slot values of deftemplate facts can be modified using the modify command.
(modify <fact - Index> <slot - modifier>+)
B where <slot-modifier> is:
(<slot -name> <slot -value>)
For example,
CLIPS> (modify O (age 24))
<Fact - 2>
CLIPS> (facts)
f - 2 (person (name "John Q. Public®)
(age 24)
(eye - color blue)
(hair - color black))
For a total of 1 fact.
CLIPS>

® A new fact index is generated for a modified fact.
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Manipulation of Facts -- duplicate

= Duplicating facts

m  duplicate command
CLIPS> (duplicate 2 (name "Jack S. Public*))
<Fact - 3>
CLIPS> (facts)
f - 2 (person (name "John Q. Public")
(age 24 )
(eye - color blue)
(hair - color black))
f - 3 (person (name "Jack S. Public")
(age 24)
(eye - color blue)
(hair - color black))
For a total of 2 facts.
CLIPS>

m The modify and duplicate commands cannot be used with ordered facts.

m To enable the duplicate command, the following command may be required:

(set -fact - duplication TRUE)
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Manipulation of Facts -- watch

The watch command is useful for debugging programs.
(watch <watch-item>)
m where <watch-item> is one of the symbols facts, rules, activations,

statistics, compilations, focus, deffunctions, globals, generic-functions,
methods, instances, slots, messages, message-handlers, or all.

If facts are being watched, CLIPS will automatically print a message
indicating that an update has been made to the fact list whenever facts are
asserted or retracted.

The effects of a watch command may be turned off by using the
corresponding unwatch command.

(unwatch <watch-item>)

SEG 7450




Manipulation of Facts -- watch

CLIPS> (facts 3 3)
f-3 (person (name  "Jack S. Public")
(age 24)
(eye-color blue)
(hair-color black))
For a total of 1 fact.
CLIPS> (watch facts)
CLIPS> (modify 3 (age 2))
<==1-3 (person (name  "Jack S. Public")
(age 24)
(eye-color blue)
(hair-color black))
(person (name "Jack S. Public")
(age 25)
(eye - color blue)
(hair - color black) )
<Fact - 4>
CLIPS>
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The Deffacts Construct

It 1s often convenient to be able to automatically assert a set of facts instead
of typing in the same assertions from the top level.

This is particularly true for facts that are known to be true before running a
program (i.e., the initial knowledge).
Groups of facts that represent initial knowledge can be defined using the
deffacts construct.
( deffacts people "Some people we know"
(person (name "John Q. Public") (age 24)
(eye - color blue) (hair - color black))
(person (name "Jack S. Public") (age 24)
(eye - color blue) (hair - color black))
(person (name "Jane Q. Public") (age 36)
(eye - color green) (hair - color red)))
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The Deffacts Construct

m  The general format of a deffacts is:

( deffacts <deffacts name> [<optional comment>]
<facts>*)

m The facts in a deffacts statement are asserted using the CLIPS reset command.
The reset command removes all facts from the fact list and then asserts the
facts from existing deffacts statement.

(reset)

m FBven if you have not defined any deffacts statements, a reset will assert the
fact (initial-fact).

m The fact identifier of the initial-fact is always £-0.
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The Components of a Rule

Rules can be typed directly into CLIPS or loaded in from a file of rules.

The pseudocode for one of the possible rules in the industrial plant
monitoring expert system 1s shown as follows:
IF the emergency is a fire
THEN the response is to activate
the sprinkler system
Before converting the pseudocode to a rule, the deftemplates for the types of
facts referred to by the rule must be defined.

(deftemplate emergency (slot type))

m  where the #pe field of the emergency tact would contain symbols such as fire, flood,
and power outage.
(deftemplate response (slot action))

m  where the action field of the response tact indicates the response to be taken.

The rule expressed in CLIPS is:
(defrule fire -emergency *“An example rule"
(emergency (type fire))
=>
(assert (response (action activate - sprinkler - system))))
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The Components of a Rule

The general format of a rule is:
(defrule  <rule name> [<comment>]
<patterns>* ; Left - Hand Side (LHS) of the rule
=>
<actions>* ); Right - Hand Side (RHS) of the rule

The entire rule must be surrounded by parentheses and each of the patterns
and actions of the rule must be surrounded by parentheses.

A rule may have multiple patterns and actions. The parentheses surrounding
patterns and actions must be properly balanced if they are nested.

The header of the rule consists of three parts. The rule must start with the
defrule keyword, followed by the name of the rule.

Next comes an optional comment string.
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The Components of a Rule

= Example:

; Rule header
(defrule  fire -emergency “An example rule"
; Patterns
(emergency (type fire))
- THEN arrow
=>
: Actions

(assert (response (action activate - sprinkler -
system))))

m  After the rule header are zero or more conditional elements (CEs). The
simplest type of CE is a pattern CE or simply pattern.
= Each pattern consists of one or more constraints intended to match the
fields of a deftemplate fact.
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The Components of a Rule

CLIPS attempts to match the patterns of rules against facts in the fact list.

m [f all the patterns of a rule match facts, the rule is activated and put on
the agenda, the collection of activated rules.

The arrow 1s a symbol representing the beginning of the THEN part of an
IF-THEN rule.

m The part of the rule before the arrow 1s called the left-hand side (LHS)
and the part after the arrow 1s called the right-hand side (RHS).

The last part of a rule 1s the list of actions that will be executed when the rule
fires.

= A program normally ceases execution when there are no rules on the
agenda.

= When there are multiple rules on the agenda, CLIPS automatically
determines which is the appropriate rule to fire.
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The Agenda and Execution

m Execution -- run

m A CLIPS program can be made to run with the run command. The syntax of
the 7un command is:

(run [<limit>])

®  where the optional argument <limit> >is the maximum number of rules to be

fired.

m If <limit> is not included or <limit> is -1, rules will be fired until none
are left on the agenda.

m Reset

® Because rules require facts to execute, the resef command is the key method for
starting or restarting an expert system in CLIPS.
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Displaying the Agenda

m The list of rules on the agenda can be displayed with the agenda command.
(agenda)
m FExample:
CLIPS> (reset)
CLIPS> (assert (emergency (type fire)))
<Fact - 1>
CLIPS> (agenda)
O fire -emergency: f-1
For a total of 1 activation.
CLIPS>

m The 0 indicates the salience of the rule on the agenda.
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Rules and Refraction

With the fire-emergency rule on the agenda, the 747 command will now cause the
rule to fire.

The fact (response (action activate-sprinkler-system» will be added to the fact
list as the action of the rule:

CLIPS> (run)

CLIPS> (facts)

f-0 (initial - fact)

f-1 (emergency (type fire))

f-2 (response (action activate
sprinkler - system))

For a total of 3 facts.

CLIPS>

®  Rules in CLIPS exhibit a property called refraction, which means they won't
fire more than once for a specific set of facts.

= Refresh
m The refresh command can be used to make the rule fire again.

m (refresh <rule - name>)
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Watching Activations, Rules, and
Statistics

m  Examples of watching activations:
CLIPS> (reset)
CLIPS> (watch acti vati ons)
CLIPS> (assert (energency (type fire)))
==> Activation O fire -emergency.f -|
<Fact - 1>
CLIPS> (agenda)
O fire -emergency: f-1
For a total of 1 activation.
CLIPS> (retract 1)
<== Activation O fire -emergency:f -1
CLIPS> (agenda)
CLIPS>
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Watching Activations, Rules, and
Statistics

m  Rules being watched:

CLIPS> (reset)

CLIPS> (watch rul es)

CLIPS> (assert (energency (type fire)))
==> Activation O fire -emergency.f -|
<Fact - 1>

CLIPS> (run)

FIRE 1 fire -emergency: f-I

CLIPS> (agenda)

CLIPS>
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Watching Activations, Rules, and
Statistics

m If statistics are watched, informational messages will be printed at the
completion of a run.

CLIPS> (unwatch all)

CLIPS> (reset)

CLIPS> (watch statistics)

CLIPS> (assert (energency (type fire)))
<Fact - 1>

CLIPS> (run)

1 rules fired Run time is 0.02 seconds

50.0 rules per second

3 mean number of facts (3 maximum)

1 mean number of instances (1 maximum)
1 mean number of activations (1 maximum)
CLIPS> (unwatch statistics)
CLIPS>
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Watching Activations, Rules, and
Statistics

CLIPS keeps statistics on the number of facts, activations, and instances.

B The mean number of facts is the sum of the total number of facts in the fact list
after each rule firing divided by the number of rules fired.
The mean and maximum numbers of activations statistics indicate the average
number of activations per rule firing and the largest number of activations on
the agenda for anyone rule firing.
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Commands for Manipulating
Constructs

Displaying the List of Members of a Specified Construct
m (list-defrul es)

m (list-deftenpl ates)

m (list-deffacts)

Displaying the Text Representation of a Specified Construct Member
m (ppdefrul e <defrul e- nane>)

m (ppdeftenpl ate <deftenpl at e- nane>)

m (ppdeffacts <deffacts-nane>)

Deleting a Specified Construct Member

m (undefrul e <defrul e- nane>)

m (undeftenpl ate <deftenpl at e- nane>)

m (undeffacts <derfacts-nane>)

Clearing All Constructs from the CLIPS Environment

m (clear)
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The PRINTOUT Command

Besides asserting facts in the RHS of rules, the RHS can also be used to print
out information using the printout command.
(printout <logical - name> <print - items>%)

® where <logical-name> indicates the output destination ot the printont command
and <print-items>* are the zero or more items to be printed by this command.

Example of rule using the printout command:
(defrule fire -emergency
(emergency (type fire))
=>
(printout t “ Activate the sprinkler system"
crif ))

The logical name 7 tells CLIPS to send the output to the standard output
device of the computer, usually the terminal.
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Using Multiple Rules

m In addition to the fire-emergency tule, the expert system monitoting the
industrial plant might include a rule for emergencies in which nooding has
occurred.

(defrule  fire - emergency
(emergency (type fire))
=
(printout t "Activate the sprinkler system"
crif ))
(defrule  flood - emergency
(emergency (type flood))
=
(printout t "Shut down electrical equipment"
crif ))
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Using Multiple Rules

m Rules with more than one pattern could be used to express these conditions.
( deftemplate extinguisher - system
(slot type)
(slot status))
(defrule class - A-fire -emergency
(emergency (type class - A- fire))
(extinguisher - system (type water - sprinkler)
(status off))
=>
(printout t "Activate water sprinkler" crif )
(defrule class - B-fire -emergency
(emergency (type class - B- fire))
(extinguisher - system (type carbon - dioxide)
(status off))
=>
(printout t "Use carbon dioxide extinguisher"
crif ))
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Using Multiple Rules

= Any number of patterns can be placed 1n a rule.

= The important point to realize is that the rule is placed on the agenda only
it all the patterns are satisfied by facts.

m This type of restriction is called an and conditional element.
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The SET-BREAK Command

m  CLIPS has a debugging command called sez-break that allows execution to be
halted before any rule from a specified group of rules is fired.

= A rule that halts execution before being fired 1s called a breakpoint.

(set-break <rule-name>)
= Example with the following rules:

(defrule first

=>

assert (fire second)))
(defrule second

(fire second)

=>

assert (fire third)))
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The SET-BREAK Command

m With set-break

CLIPS> (set-break second)
CLIPS> (reset)

CLIPS> (run)

FILE 1 first: f-O0
Breaking on the second
CLIPS>

m The show-breaks command can be used to list all breakpoints. Its syntax is:
(show - breaks)

m The remove-break command can be used to remove breakpoints. Its syntax
(remove - break [<rule - name>])
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Loading and Saving Constructs

m Loading Constructs from a File
(load <file - name>)

m where <file-name> is a string or symbol containing the name of the file to be

loaded.
= E.g. (load “fire.clp”)

m  Saving Constructs to a File

B The save command allows the set of constructs stored in CLLIPS to be saved to a

disk file.
(save <file - name>)
m H.g. (save “fire.clp”)
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Commenting Constructs

m A comment in CILPS is any text that begins with a semicolon and ends with a
carriage return.

m Jtis good to include comments describing the constructs, and giving
information regarding the program.

; kkkkkkkkkkkkkkkkkkkkkkkkkkk
.* Programmer: G. D. Riley *
* Title: The Fire Program *
;* Date: 05/17/04 *
;  Deftemplate

( deftemplate emergency “template #1 "~

(slot type)) ; What type of emergency

( deftemplate response “template #2 "~
(sloto type)) ; How to respond

; The purpose of this rule is to activate
; the sprinkler if there is a fire
(defrule  fire -emergency “An example rule
(emergency (type fire))
=> ; THEN
;Activate the sprinkler system
(assert (response (action activate - sprinker - system))))
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